Contact Free trial Login

Using Maven in Mule

Mule Runtime Engine versions 3.5, 3.6, and 3.7 reached End of Life on or before January 25, 2020. For more information, contact your Customer Success Manager to determine how you can migrate to the latest Mule version.

The pages in this section detail how to use maven outside of Anypoint Studio, working directly with Mule. You can use Mule plugins to develop your Mule applications within Maven, and to control Mule ESB instances from within a Maven environment.

To work with Maven outside Studio, you need to modify your Maven installation to enable it to work with Mule. These modifications entail adding support for Mule plugins and adding the MuleSoft community or Enterprise repositories.

Note: Mule supports any Maven 3.x version for use with Mac, Windows, and Linux.

This section contains the following pages:

Was this article helpful?

💙 Thanks for your feedback!

Edit on GitHub