Contact Free trial Login

Supported Software and Systems

MuleSoft recommends against deployments to Mule 3.8. Standard Support for this version ended on November 16, 2018, and Mule 3.8 will reach its End of Life on November 16, 2021, when Extended Support ends.

Mule Runtime runs as a standalone server on operating systems that support one of the required Java versions. An application server is not required; however, Mule Runtime can run under one. Mule Runtime does not require a database unless you need to access a data store.

Software Version

Operating systems

MacOS 10.11.4, HP-UX 11i V3, AIX 7.2, Windows 2012 R2 Server, Windows 8.1, Solaris 11.3, RHEL 7, Ubuntu Server 15.04 - 16.04

Application servers

Tomcat 7 and 8, WebLogic 12c, WebSphere 8, WildFly 8 and 9, Jetty 8 and 9

Databases

Oracle 11g, Oracle 12c, MySQL 5.5+, IBM DB2 10, PostgreSQL 9, Derby 10, Microsoft SQL Server 2014

The unified Mule Runtime 3.8.5 is compatible with APIkit 3.8.5.

Mule Runtime 3.8.5 is bundled with the Runtime Manager Agent plugin version 1.7.1.

Was this article helpful?

💙 Thanks for your feedback!

Edit on GitHub