Nav

Hardware and Software Requirements

Recommended minimum hardware is:

  • 2GHz CPU or 1 virtual CPU in virtualized environments

  • 1GB of RAM

  • 4GB of storage

Adjust RAM to match your latency requirements and the size and number of simultaneous messages that applications process.

Software requirements are:

  • One of the following Java versions:

    • Oracle JDK 1.7.0 and 1.8.0, JRE 1.7.0 or JRE 1.8.0 (JRE 1.8.0_91/92 recommended)

    • IBM JRE 1.8

    • OpenJDK 8 (JRE 1.8.0_92 recommended)

  • For Microsoft Dynamics GP connector install one of the following JCE versions after installing JRE or JDK:

    • Java Cryptography Extension (JCE) 8]

    • JCE 7 unlimited strength jurisdiction policy files

Mule Runtime is tested against operating systems listed in the "Supported Software and Systems" table.

Anypoint Connector DevKit Requirements

Anypoint Connector DevKit 3.5 and later is compatible with Mule versions 3.5 and later. DevKit version numbering does not correspond to Mule versions. For example, DevKit 3.9 is compatible with Mule versions 3.5-3.8. For the latest fixes and improvements, use the current version of Mule with its corresponding DevKit as listed in release notes.