+

Amazon Redshift Connector Release Notes - Mule 4

Support Category: Select

Amazon Redshift is a fast, fully managed cloud data warehouse that makes it simple and cost-effective to analyze all your data using standard SQL and your existing Business Intelligence (BI) tools.

Anypoint Connector for Amazon Redshift enables you to securely read data from, or write data to Amazon Redshift. Amazon Redshift objects can be used as sources and targets in data synchronization tasks, mappings, and so on. The connector enables you to move data from any data source to Amazon Redshift.

1.0.5

June 2, 2022

Compatibility

Software Version

Mule Runtime

4.3.0 and later

Anypoint Studio

7.5 and later

OpenJDK

8 or 11

Fixed Issues

Issue ID

Fixed reported security vulnerabilities by upgrading the Netty Common library from io.netty:netty-common:4.1.71.Final to io.netty:netty-common:4.1.77.Final.

W-11124603

1.0.4

April 6, 2022

Compatibility

Software Version

Mule Runtime

4.3.0 and later

Anypoint Studio

7.5 and later

OpenJDK

8 or 11

Fixed Issues

Issue ID

Fixed reported security vulnerabilities by upgrading the Jackson Databind library from com.fasterxml.jackson.core:jackson-databind:2.13.1 to com.fasterxml.jackson.core:jackson-databind:2.13.2.2.

W-10920455

1.0.3

January 11, 2022

Compatibility

Software Version

Mule Runtime

4.3.0 and later

Anypoint Studio

7.5 and later

OpenJDK

8 or 11

Fixed Issues

Issue ID

Updated the com.fasterxml.jackson.core library to 2.13.1 to address security vulnerabilities.

CONN-9811

1.0.2

December 15, 2021

Compatibility

Software Version

Mule Runtime

4.3.0 and later

Anypoint Studio

7.5 and later

OpenJDK

8 or 11

Fixed Issues

Issue ID

Upgraded the io.netty.codec library.

CONN-9556

Upgraded library dependencies.

N/A

1.0.1

July 19, 2021

Compatibility

Software Version

Mule Runtime

4.3.0 and later

Anypoint Studio

7.5 and later

OpenJDK

8 or 11

Fixed Issues

  • Stopped using a vulnerable dependency. (CONN-8525)

  • Fixed a class loading issue. (CONN-8387)

1.0.0

May 6, 2021

Compatibility

Software Version

Mule Runtime

4.3.0 and later

Anypoint Studio

7.5 and later

OpenJDK

8 or 11

Features

New connector.

Was this article helpful?

💙 Thanks for your feedback!