Nav

MUnit 1.3.5 Release Notes

We are happy to announce the new release of MUnit version 1.3.5, this release include vital library upgrades.

  • Mule MUnit Support:

    • 3.7.8

    • 3.8.5

  • Munit

    • 1.3.5

  • MUnit Studio Plugin

    • 1.5.3

Hardware and Software Requirements

  • Microsoft Windows 8

  • Apple Mac OS X 10.10

  • Linux (tested on Ubuntu 15)

  • Java 7, Java 8

  • Maven 3.1+

Compatibility

Software Version

Mule

3.6.x, 3.7.x, 3.8.x

Anypoint Studio

6.3.0 and newer

Features and Functionality

Anypoint Studio Plugin

There are no new features in this release

MUnit Runtime

There are no new features in this release

Fixed Issues

  • MUSP-491 - Update unsafe dependency

  • MU-1152 - Review security vulnerable dependencies jackson-databind, xercesImpl and xstream

Enhancements

  • MU-1116 - Upgrade Xstream 1.2 from Munit Mule Extension Loader

  • MU-1115 - Ensure application name is send to Run configuration builder

Tests that work in 1.0.0 also work in 1.3.5

Support