Contact Free trial Login

Anypoint Studio 7.0 with Mule Runtime Engine 4.0.0 Update Site 2 Release Notes

December 19, 2017
Build ID: 201712182117

Compatibility

Product

Version

Mule Runtime

Version: 4.0.0 EA

Anypoint Studio

Version: 7.0.0
Build Id: 201712182117

Maven

Version: 3.3.9

DataWeave

Version: 2.0.0

MUnit

Version: 2.0.0 (munit-studio-plugin)

Eclipse

Version: 4.6.2

What’s New

This Patch version of Studio has APIKit 1.0.1 and a bug fixes.

Migration Guide

For first time installment, please refer to Anypoint Studio 7.0.0 EA with Mule Runtime Engine 4.0.0 Release Notes for hardware requirements and known issues.

Studio 7 only supports Mule 4 projects. The structure of the project, export format, XML and scripting language are different.
Users must migrate Mule 3 projects to Mule 4 manually, before they can be used in Studio 7. See Migrating Core Components for a list of changes.

From the previous version of Studio 7.0 there is no special migration needed.

JIRA Ticket List for Anypoint Studio

Bug Fixes

  • STUDIO-10355 - Runtime and Connectors don’t load after upgrading Studio

Tasks

  • STUDIO-10357 - Update Apikit dependencies to 1.0.1

Was this article helpful?

💙 Thanks for your feedback!