Contact Free trial Login

Deploy Applications and API Proxies to Runtime Fabric

Anypoint Runtime Fabric enables you to deploy Mule applications and API Proxies to a Mule runtime managed on Runtime Fabric.

Supported Mule Runtimes

Anypoint Runtime Fabric supports deploying to the following versions of Mule runtime:

  • 3.8.7, 3.9.1, 3.9.2

  • 4.1.2, 4.1.3, 4.1.4

Prerequisites

Before deploying a Mule application or API proxy to Runtime Fabric, perform the following:

  • Install and configure a Runtime Fabric.

  • Publish your Mule application or API proxy to Exchange. Before deploying to Runtime Fabric, Mule applications and API proxies must first be published to Exchange. When deploying from Runtime Manager, this action is performed automatically.

  • Ensure that you understand how resources are allocated as described in Resource Allocation on Anypoint Runtime Fabric

Deploy Using Runtime Manager

You can manually deploy Mule applications and API proxies using Runtime Manager. See Deploy a Mule Application to Runtime Fabric

Deploy Using Maven

Runtime Fabric supports Maven for managing and deploying a Mule application or API proxy. See the following topics for information specific to the version of Mule runtime your application supports:

We use cookies to make interactions with our websites and services easy and meaningful, to better understand how they are used and to tailor advertising. You can read more and make your cookie choices here. By continuing to use this site you are giving us your consent to do this.