Select a Different JRE to Run the Embedded Mule Runtime Engine

You can select any of your installed JREs as the default Java runtime environment that Studio uses to run your Mule project.

You can change your JRE if you have a specific JDK of Java 11 that you must use or to downgrade to JDK 1.8 to run applications in Mule runtime engine 4.1.x and earlier.

Select the JRE Version for All your Studio Projects

  1. In Studio, click Anypoint Studio, and Preferences.

  2. Under Java, Installed JREs, select the JRE version you want to use.

    installed jres

    If your installed JRE version does not appear, you need to configure it:

    1. Go to Add…​, and select your type of installed JRE:

      • MacOS X VM for MacOS.

      • Standard VM for Windows and Linux.

    2. Click Next.

    3. In the JRE Home, click Directory and select the folder where your JRE is installed.
      For example, /Library/Java/JavaVirtualMachines/jdk-11.0.3.jdk/Contents/Home

    4. In JRE Name type in a descriptive name for the JRE.
      For example, Java SE 11.

    5. Click Finish.

Select the JRE Version for a Specific Project

  1. Right click in your Studio project.

  2. Navigate to Build Path, and click Configure Build Path…​.

  3. In the Libraries tab, select your JRE System Library and click Edit.

  4. Select the Alternate JRE option, and select your desired JRE from the drop-down menu.

    change jdk project

Was this article helpful?

💙 Thanks for your feedback!

Edit on GitHub