Nav

FTPS Connector Release Notes

Version 1.0.9 - October 20, 2016

Release Notes for version 1.0.9 of the FTPS connector. These release notes accompany the FTPS Connector Guide.

Version 1.0.9 - Compatibility

The FTPS connector is compatible with:

Application/Service

Version

Mule Runtime

3.6.x and later

FTPS

This connector works with any FTP server with built-in TLS/SSL support.

Version 1.0.9 - Migrating from Older Versions

No migration steps required.

Version 1.0.9 - Fixed in this Release

Version 1.0.9 - Known Issues

  • Server certificate validation on CloudHub is not supported.

  • SSL session reuse is not supported.

Version 1.0.8 - September 23, 2016

Release Notes for version 1.0.8 of the FTPS connector. These Release Notes accompany the FTPS Connector Guide.

Version 1.0.8 - Compatibility

The FTPS connector is compatible with:

Application/Service

Version

Mule Runtime

3.6.x and later

FTPS

This connector works with any FTP server with built-in TLS/SSL support.

Version 1.0.8 - Migrating from Older Versions

No migration steps required.

Version 1.0.8 - Fixed in this Release

  • b2b-provider-api updated to the latest release.

Version 1.0.8 - Known Issues

  • Server certificate validation on CloudHub is not supported.

  • SSL session reuse is not supported.

Version 1.0.7 - July 19th, 2016

Release Notes for version 1.0.7 of the FTPS connector. These Release Notes accompany the user guide.

Version 1.0.7 - Compatibility

The FTPS connector is compatible with:

Application/Service Version

Mule Runtime

3.6.x and higher.

FTPS

This connector works with any FTP server with built-in TLS/SSL support.

Version 1.0.7 - Migrating from Older Versions

No migration steps required.

Version 1.0.7 - Fixed in this Release

  • Reading threads remained active after application disposal.

Version 1.0.7 - Known Issues

  • Server certificate validation on CloudHub is not supported.

  • SSL session reuse is not supported.

Version 1.0.6 - July 11, 2016

Release Notes for version 1.0.6 of the FTPS connector. These Release Notes accompany the user guide.

Version 1.0.6 - Compatibility

The FTPS connector is compatible with:

Application/Service Version

Mule Runtime

3.6.x and higher.

FTPS

This connector works with any FTP server with built-in TLS/SSL support.

Version 1.0.6 - Migrating from Older Versions

No migration steps required.

Version 1.0.6 - Fixed in this Release

  • Anypoint Partner Manager tracking was not sending erroneous partner identifier.

Version 1.0.6 - Known Issues

  • Server certificate validation on CloudHub is not supported.

  • SSL session reuse is not supported.

Version 1.0.5 - June 13, 2016

Version 1.0.5 - Compatibility

The FTPS connector is compatible with:

Application/Service Version

Mule Runtime

3.6.x and higher

FTPS

This connector works with any FTP server with built-in TLS/SSL support.

Version 1.0.5 - Migrating from Older Versions

No migration steps required.

Version 1.0.5 - Fixed in this Release

  • Connector was throwing an exception upon host and port mismatches between control and data channels.

  • 'Move to' directory existence now checked using CHD instead of STAT prevents connector from failing when not supported.

Version 1.0.5 - Known Issues

  • Server certificate validation on CloudHub is not supported.

  • SSL session reuse is not supported.

Version 1.0.4 - March 30th, 2016

Version 1.0.4 - Compatibility

The FTPS connector is compatible with:

Application/Service Version

Mule Runtime

3.6.x and higher.

FTPS

This connector works with any FTP server with built-in TLS/SSL support

Version 1.0.4 - Migrating from Older Versions

No migration steps required.

Version 1.0.4 - Fixed in this Release

  • 'Polling frequency' setting in TPM being ignored by the connector configuration.

  • Transmission errors now published to TPM.

Version 1.0.4 - Known Issues

  • Server certificate validation on CloudHub is not supported.

Version 1.0.3 - January 14th, 2016

Version 1.0.3 - Compatibility

The FTPS connector is compatible with:

Application/Service Version

Mule Runtime

3.6.x and higher.

FTPS

This connector works with any FTP server with built-in TLS/SSL support

Version 1.0.3 - Migrating from Older Versions

No migration steps required.

Version 1.0.3 - Fixed in this Release

  • Changes made in the Trading Partner Manager configuration are not being updated on a running Mule application.

  • 'Move to directory' setting on Trading Partner Manager was being ignored.

Version 1.0.3 - Known Issues

  • Server certificate validation on CloudHub is not supported.

Version 1.0.2 - December 18th 2015

Release Notes for version 1.0.2 of the FTPS connector.

Version 1.0.2 - Compatibility

The FTPS connector is compatible with:

Application/Service Version

Mule Runtime

3.6.x and higher.

FTPS

This connector works with any FTP server with built-in TLS/SSL support

Version 1.0.2 - Migrating from Older Versions

No migration steps required.

Version 1.0.2 - Fixed in this Release

  • Solved issue on Windows with failing write operations due to misinterpreted slashes.

Version 1.0.2 - Known Issues

  • Server certificate validation on CloudHub is not supported.

  • Changes made in the Trading Partner Manager configuration are not being updated on a running Mule application.

Version 1.0.1 - November 2015

Version 1.0.1 - Compatibility

The FTPS connector is compatible with:

Application/Service Version

Mule Runtime

3.6.x and higher.

FTPS

This connector works with any FTP server with built-in TLS/SSL support

Version 1.0.1 - Migrating from Older Versions

No migration steps required.

Version 1.0.1 - Fixed in this Release

  • Write operation failed if trailing slash was not included in the path.

  • Polling frequency setting was not being read from APM when a Partner Manager Config was used.

  • If no filename is specified the FTPS Connector will read all files in the set path.

Version 1.0.1 - Known Issues

  • Server certificate validation on CloudHub is not supported.

Version 1.0.0 - November 11th 2015

Version 1.0.0 - Compatibility

The FTPS connector is compatible with:

Application/Service Version

Mule Runtime

3.6.x and higher.

FTPS

This connector works with any FTP server with built-in TLS/SSL support

Version 1.0.0 - Migrating from Older Versions

No migration steps required.

Version 1.0.0 - Features

  1. FTPS Connector goes MuleSoft Certified.

Version 1.0.0 - Known Issues

  • Server certificate validation on CloudHub is not supported.

Support Resources

  • Learn how to Install and Configure Anypoint Connectors in Anypoint Studio Installing Connectors.

  • Access MuleSoft’s Forums to pose questions and get help from MuleSoft’s broad community of users.

  • To access MuleSoft’s expert support team, subscribe to Mule ESB Enterprise and log in to MuleSoft’s Customer Portal.