Amazon Kinesis Connector Release Notes - Mule 4

Anypoint Connector for Amazon Kinesis Data Streams (Amazon Kinesis Data Streams Connector) provides access to standard Amazon Kinesis Data Stream operations using Anypoint Platform.

1.0.9

December 20, 2021

Compatibility

Software Version

Mule

4.3.0 and later

OpenJDK

8 or 11

Amazon-Kinesis-Client

2.3.4

Amazon-Kinesis-Producer

0.14.6

Fixed Issues

Issue ID

Upgraded the io.netty.codec library.

CONN-9551

1.0.8

October 4, 2021

Compatibility

Software Version

Mule

4.3.0 and later

OpenJDK

8 or 11

Amazon-Kinesis-Client

2.3.4

Amazon-Kinesis-Producer

0.14.6

Fixed Issues

Issue ID

Removed the vulnerabilities caused by the Kafka library.

CONN-8944

1.0.7

July 19, 2021

Compatibility

Amazon Kinesis Data Streams Connector 1.0.7 is compatible with:

Software Version

Mule

4.3.0 and later

OpenJDK

8 or 11

Amazon-Kinesis-Client

2.3.4

Amazon-Kinesis-Producer

0.14.6

Fixed Issues

  • Stopped using a vulnerable dependency. (CONN-8583)

1.0.6

July 13, 2021

Compatibility

Amazon Kinesis Data Streams Connector 1.0.6 is compatible with:

Software Version

Mule

4.3.0 and later

OpenJDK

8 or 11

Amazon-Kinesis-Client

2.3.4

Amazon-Kinesis-Producer

0.14.6

Fixed Issues

  • Stopped using a vulnerable dependency. (CONN-8525)

1.0.5

April 15, 2021

Compatibility

Amazon Kinesis Data Streams Connector 1.0.5 is compatible with:

Software Version

Mule

4.3.0 and later

OpenJDK

8 or 11

Amazon-Kinesis-Client

2.3.4

Amazon-Kinesis-Producer

0.14.6

Fixed Issues

  • Updated the versions of the netty-codec dependencies.

1.0.4

March 17, 2021

Compatibility

Amazon Kinesis Data Streams Connector 1.0.4 is compatible with:

Software Version

Mule

4.3.0 and later

OpenJDK

8 or 11

Amazon-Kinesis-Client

2.3.4

Amazon-Kinesis-Producer

0.14.6

Fixed Issues

  • Removed vulnerable transitive dependencies.

1.0.3

March 2, 2021

Compatibility

Amazon Kinesis Data Streams Connector 1.0.3 is compatible with:

Software Version

Mule

4.3.0 and later

OpenJDK

8 or 11

Amazon-Kinesis-Client

2.3.3

Amazon-Kinesis-Producer

0.14.4

Amazon Kineses Data Streams Connector doesn’t support Windows because it uses the Kinesis Producer Library (KPL), which deprecated Windows support starting in version v0.14.0.

Fixed Issues

  • An expired role session wasn’t automatically renewed. (SE-19719)

1.0.2

February 16, 2021

Compatibility

Amazon Kinesis Data Streams Connector 1.0.2 is compatible with:

Software Version

Mule

4.3.0 and later

OpenJDK

8 or 11

Amazon-Kinesis-Client

2.3.3

Amazon-Kinesis-Producer

0.14.4

Fixed Issues

  • Updated the versions of multiple dependencies. (CONN-7710, CONN-7713)

1.0.1

February 11, 2021

Compatibility

Amazon Kinesis Data Streams Connector 1.0.1 is compatible with:

Software Version

Mule

4.3.0 and later

OpenJDK

8 or 11

Fixed Issues

  • Removed the vulnerabilities caused by the Jackson Dataformat: CBOR library (CONN-7656).

1.0.0

November 13, 2020

Compatibility

Amazon Kinesis Data Streams Connector 1.0.0 is compatible with:

Software Version

Mule

4.3.0 and later

OpenJDK

8 or 11

Features

New connector

Known Issues

  • None

Was this article helpful?

💙 Thanks for your feedback!

Give us your feedback!
We want to build the best documentation experience for you!
Help us improve with your feedback.
Take the survey!