+

Zendesk Connector Release Notes - Mule 4

Support Category: Select

Anypoint Connector for Zendesk enables you to connect to the Zendesk’s Support API.

1.1.5

July 7, 2022

Compatibility

Software Version

Mule

4.2.1 and later

Zendesk Support API

N/A

Fixed Issues

Issue ID

Previously, when a new ticket was created, the New ticket created and Existing ticket updated sources were both invoked. Now, only the New ticket created source is invoked when creating a new ticket.

W-11264280

1.1.4

April 11, 2022

Compatibility

Software Version

Mule

4.2.1 and later

Zendesk Support API

N/A

Fixed Issues

Issue ID

Fixed reported security vulnerabilities by upgrading the Jackson Databind library from com.fasterxml.jackson.core:jackson-databind:2.13.1 to com.fasterxml.jackson.core:jackson-databind:2.13.2.2.

W-10920460

1.1.3

February 21, 2022

Compatibility

Software Version

Mule

4.2.1 and later

Zendesk Support API

N/A

Fixed Issues

Issue ID

Fixed Zendesk vulnerability regarding jackson-databind library.

W-10702347

1.1.2

February 10, 2022

Compatibility

Software Version

Mule

4.2.1 and later

Zendesk Support API

N/A

Fixed Issues

Issue ID

Optimized the connector to improve its overall stability and performance.

CSCA-1318

1.1.1

November 3, 2021

Compatibility

Software Version

Mule

4.2.1 and later

Zendesk Support API

N/A

Fixed Issues

  • Optimized the connector to improve its overall stability and performance.

1.1.0

October 5, 2021

What’s New

  • Added new operations:

    • Upsert an organization

    • Upsert a user

    • Search

  • Removed apiVersion as a default value from the baseUri connection parameter. Now, apiVersion is a separate connection parameter in all of the connection providers.

Compatibility

Software Version

Mule

4.2.1 and later

Zendesk Support API

N/A

1.0.1

February 12, 2021

Compatibility

Software Version

Mule

4.2.1 and later

Zendesk Support API

N/A

Fixed Issues

The connector was not discoverable in Anypoint Studio.

1.0.0

January 29, 2021

Compatibility

Software Version

Mule

4.2.1 and later

Zendesk Support API

N/A

Additional information can be found here:

Was this article helpful?

💙 Thanks for your feedback!