Mule Maven Plugin 3.5.1 Release Notes

Mule Maven Plugin 3.5.1 is focused on improving the plugin functionality and fixing issues.

Hardware and Software Requirements

  • Microsoft Windows 8+

  • Apple Mac OS X 10.10+

  • Linux (tested on Ubuntu 15)

  • Java 8

  • Maven 3.6.1, 3.6.2, 3.6.3, 3.8.1

Compatibility

  • Mule 4.x

  • Anypoint Studio 7.x

  • OpenJDK 11, when using Mule 4.2 or later

Features and Functionality

  • Added support for configuring an HttpClient-based HTTP wagon to access HTTP-based Maven repositories to resolve Maven dependencies when packaging your Mule application.

Fixed Issues

  • Fixed an issue that caused the error Unresolvable build extension when trying to build Mule apps using MMP 3.5.0.

  • Fixed a vulnerability to prevent malicious attacks.

Was this article helpful?

💙 Thanks for your feedback!