Header Injection Policy

1.2.1

Apr 30, 2020

Minimum Mule Version

Mule 4.1.0

New Features and Enhancements

  • Error handling responses revised for WSDL APIs to be compliant with SOAP 1.1 and 1.2.

  • Performance improvements are made to the header manipulation engine.

Fixed issues

1.2.0

September 12, 2019

Minimum Mule Version

Mule 4.1.0

New Features and Enhancements

  • Several performance improvements were introduced in this release.

Fixed Issues

  • An error occurred causing inbound and outbound headers to be set to lower case, ignoring the user input.

1.1.1

July 12, 2019

Minimum Mule Version

Mule 4.1.0

New Features and Enhancements

  • Several performance improvements were introduced in this release.

1.1.0

April 26, 2019

Minimum Mule Version

Mule 4.1.0

New Features and Enhancements

  • Introduced support for encrypting sensitive information related to the policy. The runtime version must be correctly configured to support encryption. Encryption support was introduced in Mule Runtime v4.2.0.

  • Several performance improvements were introduced in this release.

  • Policy weight was reduced.

1.0.1

October 4, 2018

Minimum Mule Version

Mule 4.1.0

Fixed Issues

  • Policy parameters has an incorrect extra escaping issue.

  • An ExpressionRuntimeException error occurred when a WSDL proxy received an empty payload, or an invalid XML.

1.0.0

March 23, 2018

Minimum Mule Version

4.1.0

Was this article helpful?

💙 Thanks for your feedback!