Contact Free trial Login

HTTP Caching Policy

1.0.2

September 12, 2019

Minimum Mule Version

4.1.0

Fixed Issues

  • An Object Store repeatedly fails to store an event, resulting in a stack overflow.

1.0.1

April 26, 2019

Minimum Mule Version

4.1.0

Fixed Issues

  • Previous version incompatible with Mule Runtime 4.2.0 and greater.

  • An error occurred when internal parameters were serialized. This is because these parameters are not serializable.

  • During a cache hit, the loaded event was using the old context, such as event Id and correlation Id), resulting in failed error handling and feedback loop.

Known Issues

  • Upgrading from a previous policy version invalidates the existing cache.

1.0.0 - Deprecated

July 03, 2018

Compatibility

  • v1.0.0 is compatible with v4.1.x and not compatible with v4.2.0 and greater of Mule Runtime.

Minimum Mule Version

4.1.0

Was this article helpful?

💙 Thanks for your feedback!

Leave feedback…