Anypoint Studio 6.6.8 Release Notes

May 27, 2021

What’s New

Anypoint Studio 6.6.8 adds official support for macOS Big Sur. See the macOS 11.x Support section in the installation instructions for more information.

Components Bundled with This Release

Mule runtime engine

Version: 3.9.4 EE

APIkit

Versions: 3.9.4

DataWeave

Version: 1.2.3

MUnit

Version: 1.7.8 (munit-studio-plugin)

Compatibility

Applications developed in Studio 6.6.8 are compatible with the following Mule runtime engine versions:

Mule Runtime Engine Version Compatible

Mule runtime engine 3.8.x

Yes

Mule runtime engine 3.9.x

Yes (Bundled)

Mule runtime engine 4.1.x

No

Mule runtime engine 4.2.x

No

Mule runtime engine 4.3.x

No

Software Requirements

  • Java Environment
    This version of Anypoint Studio requires AdoptOpenJDK 8 to run properly. Depending on which Mule runtime engine you want to use, you can configure different JDK versions within Anypoint Studio:

    • Mule 3.9.x requires Studio running on Java 8.

    • Mule 3.5.x requires Studio running on Java 7.

    • Other supported runtime versions work fine with both Java 7 or 8.

  • Operating Systems

    • macOS 10.10.0 through 11.0.x

    • Windows 7 (64-bit), Windows 8 (64-bit), Windows 10 (64-bit)

    • RHEL 7.0

    • Ubuntu 15.04 or later

Hardware Requirements

  • 8GB of memory.
    MuleSoft recommends a minimum of 4GB of free RAM available on a developer workstation. As applications become complex, consider adding more RAM.

  • 2GHz CPU.

  • 10GB free hard drive space.

Known Issues

There are no known issues for this release.

Fixed Issues

Issue Description

SE-18628

Anypoint Studio 6 now works with macOS Big Sur.

Was this article helpful?

💙 Thanks for your feedback!