Contact Free trial Login

Anypoint Studio 7.3 with Mule Runtime Engine 4.2.0 Update Site 3 Release Notes

May 2, 2019
Build ID:

Compatibility

Product

Version

Mule Runtime

Version: 4.2.0

Anypoint Studio

Version: 7.3.3
Build Id:

Maven

Version: 3.3.9

DataWeave

Version: 2.2.0

MUnit

Version: 2.3.2 (munit-studio-plugin)

Eclipse

Version: 4.7.2

Runtime Compatibility

  • Studio 7.3.3 is bundled with Mule Runtime Engine 4.2.0, however, you can use it with earlier Mule Runtime versions such as as 4.1.4.

Studio Compatibility

  • Projects created or updated with Studio 7.3.x or 7.2.x are not compatible with 7.1.x due to some improvements with the management of the mule-artifact.json file. The content of the file was reduced and part of the content used to be required by Studio 7.1.x.
    To fix this issue, you only need to update Studio to the latest 7.2.x version available. See Updating Workspaces for more information.

  • Workspaces created using Anypoint Studio 6.x or below are not compatible with Anypoint Studio 7 workspaces.

What’s New

Hardware Requirements

  • For most use cases, Anypoint Studio with the 4.2.0 Runtime does not change hardware or software requirements from the previous Studio 7 versions.

  • MuleSoft recommends a minimum of 4GB of free RAM available on a developer workstation. As applications become complex, consider adding more RAM.

  • 4GB of free memory available.

  • 2GHz CPU.

  • 10GB free hard drive space.

Software Requirements

Software

Version

Java Environments

  • AdoptOpenJDK 8

This version of Studio is not compatible with Java 9 or Java 10.
If you are having issues installing Studio, follow this guide to reconfigure your Java installation.

The only compatibility introduced for Java 11 is when using the Mule runtime engine version 4.2.0 and later.
Studio still requires Java 8 to launch and run properly. You can install and configure Java 11 on your machine, but make sure to configure this JDK to be used by the embedded 4.2.x runtime running in Studio.
See Change the JDK from Studio for instructions on how to do this.

Operating Systems

  • MacOS 10.12.0

  • Windows (32- and 64-bit) Windows 7, Windows 8, Windows 10

  • RHEL 7.0

  • Ubuntu 15.04 or later

Suggested Web Browsers by Platform.
Studio will always use the OS default web browser

  • Windows:

    • Microsoft Edge 25.0

    • Internet Explorer 11

  • Linux

    • Mozilla Firefox 51.0.1

  • OS X

    • Safari 10.1

Maven

Studio comes with Maven 3.3.9 bundled, but you can externally use the versions: 3.3.3 or your own 3.3.9

Running real-time antivirus protection software on your operating system might have a negative impact on Anypoint Studio performance. Although this issue is prominent on Windows, it also occurs on Linux and OSx.

Although the steps to solve these performance issues vary depending on your antivirus software, a typical solution is to either whitelist or exclude the Anypoint Studio and java executables, the Studio install and workspace filesystem locations, or some combination of both. See examples of solutions for McAfee Viruscan, Windows Defender, and Symantec Endpoint Protection.

Known Issues

  • This version of Studio was released with an issue causing the MUnit Studio Plugin to fail.
    Upgrade your MUnit Studio plugin to version 2.3.3 or later. Go to Anypoint Studio Update Sites for more information.

  • Studio 7 only supports Mule 4.x projects. Due to the structure of projects, export format, xml and scripting language differences, we do not offer backwards compatibility with Mule 3.x runtimes.

  • Some existing features in Studio 6.x are not yet supported in Studio 7: Custom Policies, API Sync, Anypoint Private Cloud.

  • Anypoint Studio uses your configured default browser to display web content such as Exchange and the Runtime Manager UI when deploying an application to Anypoint Platform. If your default internet browser does not display this content correctly, you can configure Anypoint Studio to use a Mozilla/XULRunner runtime environment as the underlying renderer for the Web UI.
    Follow the FAQ: Troubleshooting Issues with Your Default OS Browser for more details.

  • Copybook import fails with no message.

  • Copybook import file not copied to project.

  • Mule modules need to provide icons as today many of the modules have the generic icon.

  • The pom.xml file of a running application is not updated when changing dependencies.

  • Debugger: payload shown while debugging is partial but there is no way to view the rest of the payload

  • Mule plugins with snapshot versions should always be regenerated.

  • Datasense/Runtime not working correctly through proxy on connectors using TCP/IP or connectors which don’t yet support it.

  • When importing a project with a runtime that is not installed in Studio there is no notification to the User.

  • Define Metadata - selected schema file does not exist when an example JSON is set for the metadata type.

Bug Fixes

Fixed Developer Bugs

Closed Stories

Enhancements in This Release

Was this article helpful?

💙 Thanks for your feedback!

Edit on GitHub