Slack Connector Release Notes - Mule 4

Support Category: Select

Anypoint Connector for Slack (Slack Connector) gives you access to the Slack platform. This connector exposes operations provided by the Slack API. Visit the official Slack site to learn more.

1.0.6

October 14, 2021

Compatibility

Software Version

Anypoint Studio

7.3.5 and later

Mule runtime engine

4.2.1 and later

Open JDK

8 and 11

Fixed Issues

Issue ID

Optimized the connector to improve its overall stability and performance.

COCN-512

1.0.5

September 2, 2021

Compatibility

Slack Connector is compatible with these software versions:

Software Version

Anypoint Studio

7.3.5 and later

Mule runtime engine

4.2.1 and later

Open JDK

8 and 11

Fixed Issues

Issue ID

Optimized the connector to improve its overall stability and performance.

COCN-539, COCN-512

1.0.4

July 9, 2021

Compatibility

Slack Connector is compatible with these software versions:

Software Version

Anypoint Studio

7.3.5 and later

Mule runtime engine

4.2.1 and later

Open JDK

8 and 11

Fixed Issues

  • Optimized the connector to improve its overall stability and performance.

1.0.3

June 8, 2021

Compatibility

Slack Connector is compatible with these software versions:

Software Version

Anypoint Studio

7.3.5 and later

Mule runtime engine

4.2.1 and later

Open JDK

8 and 11

Fixed Issues

  • Improved the value provider’s error handling. (CONN-7984)

1.0.2

March 19, 2021

Compatibility

Slack Connector is compatible with these software versions:

Software Version

Anypoint Studio

7.3.5 and later

Mule runtime engine

4.2.1 and later

Open JDK

8 and 11

Fixed in This Release

  • Improved the content of some operations and their metadata. (CONN-7745)

1.0.1

February 19, 2021

Compatibility

Slack Connector is compatible with these software versions:

Software Version

Anypoint Studio

7.3.5 and later

Mule runtime engine

4.2.1 and later

Open JDK

8 and 11

Fixed in This Release

  • The connector did not appear in Studio. (CONN-7667)

  • When using the Conversations List or Users List operation, the connector failed with a null pointer exception. (CONN-7548)

1.0.0

January 22, 2021

New connector.

Compatibility

Slack Connector is compatible with these software versions:

Software Version

Anypoint Studio

7.3.5 and later

Mule runtime engine

4.2.1 and later

Open JDK

8 and 11

Features

For a list of supported configurations and operations, see the Slack Connector Reference Guide.

Fixed in This Release

Not applicable.

Was this article helpful?

💙 Thanks for your feedback!