Contact Free trial Login

Prerequisites for Using APIkit for Soap

This procedure describes how to set up the development environment for creating a WSDL-based API using APIkit.

  • Ensure that you are using the following:

    • Studio 7.1 or later

    • Mule runtime engine 4.1.1 or later

    • SOAP 1.1 or 1.2

      Studio includes the Anypoint APIkit SOAP Extension.

  • Download a SoapUI client.
    For example, SoapUI.

  • Download or obtain the URL for a WSDL file.
    For this workflow, download the WSDL tshirt2.wsdl example.

Was this article helpful?

💙 Thanks for your feedback!

Edit on GitHub