Contact Free trial Login

Hardware and Software Requirements

If you plan to install Mule and run it on premises, review these minimum hardware and software requirements before you install.

Minimum Hardware Requirements

  • 2 GHz CPU or 1 virtual CPU in virtualized environments.

  • 1 GB of RAM.

  • 4 GB of storage.

Adjust RAM to match your latency requirements and the size and number of simultaneous messages that applications process.

Required Software

Verify that you use a supported version of Java before you install Mule.

Software Version

JDK

JDK 1.8.0 or JDK 11

+ Recommended JDK: AdoptOpenJDK with the latest version of OpenJDK 8 (LTS) and the HotSpot JVM.

Supported Software

Mule is supported on any operating system that runs a Java Runtime Environment (JRE) from a supported JDK.

Tested Software

The Mule runtime engine passed functional testing against the following software and operating systems:

Software

Version

OS

MacOS 10.15, HP-UX 11i V3, AIX 7.2, Windows Server 2019, Windows 10, Solaris 11.3, RHEL 8, Ubuntu Server 20.04

JDK

JDK 1.8.0, JDK 11

This version of Mule runtime engine is bundled with the Runtime Manager agent plugin version 2.1.9.

Was this article helpful?

💙 Thanks for your feedback!

Edit on GitHub